A currency code must be specified for an amount field – Ax2012 Workflow

When working with workflow, I faced an error while activating the workflow version –  “A currency code must be specified for an amount field “
workflow1
I was not sure if it is mandatory to include the Currency field in “Activation” condition. But including that field explicitly did not help on this issue.
One of my condition for activation is including Amount field and giving some values for it. Nobody would have noticed a small grey box next to amount value. Leaving this empty would give the above said error.
workflow2
On clicking this, user is given an option to choose the currency.
workflow3
When the currency is selected , error is gone!!!!
Make sure you choose the company currency else you might end up with workflow not getting triggered for your postings…

 

Advertisements

About AnithaEswaran

Hello all, Thanks for visiting my blog. I started this blog to share my learning with Ax members . Since I am from technical background, most of my posts would be from X++. Thanks to my mentor and my colleague Romain who guided and helped me in learning many new concepts in Ax. This instilled confidence in me to handle and troubleshoot complex issues. Feedback wrt to my blog entries are most welcome …
This entry was posted in Ax2012, Workflow. Bookmark the permalink.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s